python的Django项目配置运行(pyCharm)

     阅读:26


       最近公司又来来一次优化,人手就变紧张了,但是事还是得干啊。所以,我也可能即将被拉出来补位。那么我个人也可能刚好趁这个时期深入下,不管怎么说,学习是个人的事情。今天就来跟大家分享下一个Django的python项目再pyCharm下跑起来。

一、代码下载

这个不解释,各公司的版本控制可能不一样,但是Git应该是主流。代码下载以后的目录如下:
在这里插入图片描述
我们这个是后端、前端在一起的项目。

二、配置运行环境

在这里插入图片描述
       点击小齿轮,选择add
在这里插入图片描述
       点击OK后,原界面变化如下:
在这里插入图片描述

       这里可以先升级下版本,方法就是选中行,点击红框的小尖角。如果是要批量升级,也可以下面的依赖全选,再点小尖角。

三、项目依赖包安装

       一般python项目都会有一个依赖包说明文件,requirements.txt文件,如本下面
在这里插入图片描述
       这里安装这些依赖有2种方法,一种是命令批量安装,一种是一个个安装。

  • 单个个安装

       在刚刚运行环境配置界面哪里,点击“+”,搜索包名->选择->安装,界面步骤如下:
在这里插入图片描述
       这里可以选择版本,如果勾选框不勾选,那默认就是安装的最新版本。
在这里插入图片描述
       一般安装都会同时把相应的依赖也装上的。

  • 批量安装

       进入terminal,用pip执行安装命令
在这里插入图片描述

四、启动说明

       找到入口类,配置,注意需要增加runserver参数,配置如下:
在这里插入图片描述
这里安装包以后,启动还是报错,原因是

  • Django版本高了

在这里插入图片描述
       这个文件一看就知道,这是Django3版本里的写法,而我是装的最新版4,那怎么降级呢?
还是在配置运行环境哪里操作,点击版本号,弹框勾选勾选框,选择版本,点击insatll package
在这里插入图片描述
       这里不降低版本号就要修改urls.py文件,原因:
在这里插入图片描述
       4+以上的版本,url()写法需要改成re_path(),这里说的很清楚。

  • 我用的python是最新版3.10,安装psutil是报错

在这里插入图片描述
       这个目前我没有找到解决办法,等待官网出支持3.10.x的包吧。我又安装了python3.9.9。
在这里插入图片描述

五、启动效果

       这里不方便透露更多,就上一个后端启动成功展示启动成功后的url的图吧
在这里插入图片描述

六、总结

       基本上Django的python项目在pyCharm上就是这样启动的吧。启动贼快,就是这个依赖包的版本不要瞎升级哦。